summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ungoogled-chromium-system-zlib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ungoogled-chromium-system-zlib.patch')
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-zlib.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/patches/ungoogled-chromium-system-zlib.patch b/gnu/packages/patches/ungoogled-chromium-system-zlib.patch
deleted file mode 100644
index b6e3c0f075..0000000000
--- a/gnu/packages/patches/ungoogled-chromium-system-zlib.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Use zlib instead of the bundled lzma_sdk.
-
-Adapted from Debian:
-https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/zlib.patch
-
-diff --git a/courgette/BUILD.gn b/courgette/BUILD.gn
---- a/courgette/BUILD.gn
-+++ b/courgette/BUILD.gn
-@@ -58,7 +58,6 @@ static_library("courgette_lib") {
-
- deps = [
- "//base",
-- "//third_party/lzma_sdk",
- ]
-
- public_deps = [
-@@ -79,7 +78,6 @@ source_set("courgette_common") {
- ]
- deps = [
- "//base",
-- "//third_party/lzma_sdk",
- ]
- }
-
-diff --git a/courgette/crc.cc b/courgette/crc.cc
---- a/courgette/crc.cc
-+++ b/courgette/crc.cc
-@@ -7,6 +7,8 @@
- #include <stdint.h>
- #include <stddef.h>
-
-+#define COURGETTE_USE_CRC_LIB
-+
- #ifdef COURGETTE_USE_CRC_LIB
- # include "zlib.h"
- #else
-diff --git a/third_party/perfetto/gn/BUILD.gn b/third_party/perfetto/gn/BUILD.gn
---- a/third_party/perfetto/gn/BUILD.gn
-+++ b/third_party/perfetto/gn/BUILD.gn
-@@ -304,7 +304,6 @@ if (enable_perfetto_zlib) {
- public_configs = [ "//buildtools:zlib_config" ]
- public_deps = [ "//buildtools:zlib" ]
- } else {
-- public_configs = [ "//third_party/zlib:zlib_config" ]
- public_deps = [ "//third_party/zlib" ]
- }
- }