summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/thefuck-test-environ.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/thefuck-test-environ.patch')
-rw-r--r--gnu/packages/patches/thefuck-test-environ.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/thefuck-test-environ.patch b/gnu/packages/patches/thefuck-test-environ.patch
new file mode 100644
index 0000000000..0c602a38c4
--- /dev/null
+++ b/gnu/packages/patches/thefuck-test-environ.patch
@@ -0,0 +1,14 @@
+Retain environment setting of "HOME" for tests that need os.path.expanduser()
+to return a readable directory in the build chroot.
+
+--- thefuck-3.15/tests/test_conf.py
++++ thefuck-3.15/tests/test_conf.py
+@@ -12,7 +12,7 @@
+
+ @pytest.fixture
+ def environ(monkeypatch):
+- data = {}
++ data = {"HOME": os.environ.get("HOME")}
+ monkeypatch.setattr('thefuck.conf.os.environ', data)
+ return data
+