summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch')
-rw-r--r--gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch b/gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch
deleted file mode 100644
index 9caf607940..0000000000
--- a/gnu/packages/patches/sudo-missing-sudo_pt_regs-aarch64.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From d549adf04bfde7936306203e2e8886ffd93d00ea Mon Sep 17 00:00:00 2001
-From: Pierre Bourdon <delroth@gmail.com>
-Date: Tue, 7 Jun 2022 17:14:39 +0200
-Subject: [PATCH] exec_ptrace: fix missing sudo_pt_regs on aarch64
-
-AArch64 already had an existing "user_pt_regs" struct and didn't need a
-struct alias before the renaming to "sudo_pt_regs". Make the code build
-again by adding the now missing alias.
-
-Fixes: 2eb8ff17
----
- src/exec_ptrace.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/exec_ptrace.h b/src/exec_ptrace.h
-index 7f26283a8..4a5a86581 100644
---- a/src/exec_ptrace.h
-+++ b/src/exec_ptrace.h
-@@ -76,6 +76,7 @@
- # define reg_arg4(x) (x).r10
- #elif defined(__aarch64__)
- # define SECCOMP_AUDIT_ARCH AUDIT_ARCH_AARCH64
-+# define sudo_pt_regs struct user_pt_regs
- # define reg_syscall(x) (x).regs[8] /* w8 */
- # define reg_retval(x) (x).regs[0] /* x0 */
- # define reg_sp(x) (x).sp /* sp */