summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/sbcl-geco-fix-organism-class.patch')
-rw-r--r--gnu/packages/patches/sbcl-geco-fix-organism-class.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-geco-fix-organism-class.patch b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
new file mode 100644
index 0000000000..817596241e
--- /dev/null
+++ b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
@@ -0,0 +1,13 @@
+Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
+
+--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
++++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
+@@ -148,7 +148,7 @@
+ :accessor score
+ :initarg :score
+ :initform 'nil
+- :type number)
++ :type (or number null))
+ (NORMALIZED-SCORE
+ :accessor normalized-score
+ :initarg :normalized-score