summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch')
-rw-r--r--gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch b/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
index c91d273f92..fc2c74718a 100644
--- a/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
+++ b/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
@@ -11,11 +11,11 @@ Without these additional required dependencies, linking fails with errors such a
CMakeLists.txt | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1794a07..c7b852a 100644
+diff --git a/lib/comgr/CMakeLists.txt b/lib/comgr/CMakeLists.txt
+index 8b5ca2f..a7d226f 100644
--- a/lib/comgr/CMakeLists.txt
+++ b/lib/comgr/CMakeLists.txt
-@@ -207,7 +207,11 @@ install(FILES
+@@ -294,7 +294,11 @@ install(FILES
DESTINATION "${AMD_COMGR_PACKAGE_PREFIX}")
set(CLANG_LIBS
@@ -28,7 +28,7 @@ index 1794a07..c7b852a 100644
set(LLD_LIBS
lldELF
-@@ -218,8 +222,20 @@ if (LLVM_LINK_LLVM_DYLIB)
+@@ -305,8 +309,21 @@ if (LLVM_LINK_LLVM_DYLIB)
else()
llvm_map_components_to_libnames(LLVM_LIBS
${LLVM_TARGETS_TO_BUILD}
@@ -46,7 +46,8 @@ index 1794a07..c7b852a 100644
+ IRReader
+ CodeGen
+ Linker
++ Demangle
+ BinaryFormat)
endif()
- target_link_libraries(amd_comgr
+ target_link_options(amd_comgr