summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-ipython-documentation-repro.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-ipython-documentation-repro.patch')
-rw-r--r--gnu/packages/patches/python-ipython-documentation-repro.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-ipython-documentation-repro.patch b/gnu/packages/patches/python-ipython-documentation-repro.patch
new file mode 100644
index 0000000000..d6a6e9c3fd
--- /dev/null
+++ b/gnu/packages/patches/python-ipython-documentation-repro.patch
@@ -0,0 +1,25 @@
+Fix non-reproducibilities caused by time-dependent procedures.
+Submitted upstream: https://github.com/ipython/ipython/pull/13640
+
+diff --git a/IPython/sphinxext/ipython_directive.py b/IPython/sphinxext/ipython_directive.py
+index 18bdfcae9..2c665ac87 100644
+--- a/IPython/sphinxext/ipython_directive.py
++++ b/IPython/sphinxext/ipython_directive.py
+@@ -19,7 +19,7 @@
+ In [1]: 1+1
+
+ In [1]: import datetime
+- ...: datetime.datetime.now()
++ ...: datetime.date.fromisoformat('2022-02-22')
+
+ It supports IPython construct that plain
+ Python does not understand (like magics):
+@@ -28,7 +28,7 @@
+
+ In [0]: import time
+
+- In [0]: %timeit time.sleep(0.05)
++ In [0]: %pdoc time
+
+ This will also support top-level async when using IPython 7.0+
+