summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-chardet-3.0.4-pytest.patch')
-rw-r--r--gnu/packages/patches/python-chardet-3.0.4-pytest.patch15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/patches/python-chardet-3.0.4-pytest.patch b/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
deleted file mode 100644
index d5bf7ccc28..0000000000
--- a/gnu/packages/patches/python-chardet-3.0.4-pytest.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix test failure with Pytest 4.
-
-Taken from upstream:
-https://github.com/chardet/chardet/commit/440828f8faafdb58700c64a9ea8f6a30b154c08b
-
-diff --git a/test.py b/test.py
---- a/test.py
-+++ b/test.py
-@@ -59,5 +59,5 @@ def gen_test_params():
- full_path = join(path, file_name)
- test_case = full_path, encoding
- if full_path in EXPECTED_FAILURES:
-- test_case = pytest.mark.xfail(test_case)
-+ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
- yield test_case