summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-cairocffi-dlopen-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-cairocffi-dlopen-path.patch')
-rw-r--r--gnu/packages/patches/python-cairocffi-dlopen-path.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-cairocffi-dlopen-path.patch b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
new file mode 100644
index 0000000000..e7a7fe3737
--- /dev/null
+++ b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
@@ -0,0 +1,10 @@
+--- cairocffi-0.8.0/cairocffi/__init__.py.orig 2018-07-16 11:00:59.075664158 +0200
++++ cairocffi-0.8.0/cairocffi/__init__.py 2018-07-16 17:09:42.471958015 +0200
+@@ -35,6 +35,7 @@
+ return lib
+ except OSError:
+ pass
++ return ffi.dlopen(name)
+ raise OSError("dlopen() failed to load a library: %s" % ' / '.join(names))
+
+