summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-2.7-search-paths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-2.7-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-2.7-search-paths.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-2.7-search-paths.patch b/gnu/packages/patches/python-2.7-search-paths.patch
new file mode 100644
index 0000000000..6e5339f3a6
--- /dev/null
+++ b/gnu/packages/patches/python-2.7-search-paths.patch
@@ -0,0 +1,16 @@
+Make sure the build system honors CPATH and LIBRARY_PATH when looking for
+headers and libraries.
+
+--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
++++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200
+@@ -526,6 +526,10 @@ class PyBuildExt(build_ext):
+ inc_dirs += ['/system/include', '/atheos/autolnk/include']
+ inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
+
++ # Always honor these variables.
++ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
++ inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
++
+ # OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
+ if host_platform in ['osf1', 'unixware7', 'openunix8']:
+ lib_dirs += ['/usr/ccs/lib']