summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pugixml-versioned-libdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/pugixml-versioned-libdir.patch')
-rw-r--r--gnu/packages/patches/pugixml-versioned-libdir.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/gnu/packages/patches/pugixml-versioned-libdir.patch b/gnu/packages/patches/pugixml-versioned-libdir.patch
deleted file mode 100644
index 7cd23b1a71..0000000000
--- a/gnu/packages/patches/pugixml-versioned-libdir.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-This patch makes pugixml install its headers to a standard location when
-built as a shared library.
-
-Taken from this upstream commit:
-https://github.com/zeux/pugixml/commit/daeb8013b20f9c47e85730faaa4131064a1f9c2e
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 90fa6793..d7bc1b20 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -4,7 +4,7 @@ project(pugixml)
-
- option(BUILD_SHARED_LIBS "Build shared instead of static library" OFF)
- option(BUILD_TESTS "Build tests" OFF)
--option(BUILD_PKGCONFIG "Build in PKGCONFIG mode" OFF)
-+option(USE_VERSIONED_LIBDIR "Use a private subdirectory to install the headers and libs" OFF)
-
- set(BUILD_DEFINES "" CACHE STRING "Build defines")
-
-@@ -55,7 +55,7 @@ endif()
- set_target_properties(pugixml PROPERTIES VERSION 1.9 SOVERSION 1)
- get_target_property(PUGIXML_VERSION_STRING pugixml VERSION)
-
--if(BUILD_PKGCONFIG)
-+if(USE_VERSIONED_LIBDIR)
- # Install library into its own directory under LIBDIR
- set(INSTALL_SUFFIX /pugixml-${PUGIXML_VERSION_STRING})
- endif()
-@@ -71,10 +71,8 @@ install(TARGETS pugixml EXPORT pugixml-config
- install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}${INSTALL_SUFFIX})
- install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
-
--if(BUILD_PKGCONFIG)
-- configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
-- install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
--endif()
-+configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
-+install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-
- if(BUILD_TESTS)
- file(GLOB TEST_SOURCES tests/*.cpp)
-diff --git a/scripts/pugixml.pc.in b/scripts/pugixml.pc.in
-index 3c97c28d..804c4d38 100644
---- a/scripts/pugixml.pc.in
-+++ b/scripts/pugixml.pc.in
-@@ -1,11 +1,11 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- exec_prefix=${prefix}
--includedir=${prefix}/include/pugixml-@PUGIXML_VERSION_STRING@
--libdir=${exec_prefix}/lib/pugixml-@PUGIXML_VERSION_STRING@
-+includedir=${prefix}/include@INSTALL_SUFFIX@
-+libdir=${exec_prefix}/lib@INSTALL_SUFFIX@
-
- Name: pugixml
- Description: Light-weight, simple and fast XML parser for C++ with XPath support.
- URL: http://pugixml.org/
- Version: @PUGIXML_VERSION_STRING@
- Cflags: -I${includedir}
--Libs: -L${libdir} -lpugixml
-\ No newline at end of file
-+Libs: -L${libdir} -lpugixml