summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mutt-store-references.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mutt-store-references.patch')
-rw-r--r--gnu/packages/patches/mutt-store-references.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/patches/mutt-store-references.patch b/gnu/packages/patches/mutt-store-references.patch
index 3b69c7b0bd..77d1680d60 100644
--- a/gnu/packages/patches/mutt-store-references.patch
+++ b/gnu/packages/patches/mutt-store-references.patch
@@ -2,15 +2,16 @@ By default 'mutt' embeds configure flags and the output of 'gcc -v',
which contains the store file name of Bash and GCC. This patch makes
sure we don't embed a reference to these in 'mutt'.
---- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
-+++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
+diff --git a/txt2c.sh b/txt2c.sh
+index f634bb9..53845cf 100755
+--- a/txt2c.sh
++++ b/txt2c.sh
@@ -21,6 +21,8 @@ txt2c_fallback () {
echo ";"
}
+echo "unsigned char $1[] = \"value of '$1' not kept\";"
+exit 0
- ./txt2c test </dev/null >/dev/null 2>&1 &&
- ./txt2c "$1" ||
- txt2c_fallback "$1"
-
+ if ./txt2c test </dev/null >/dev/null 2>&1; then
+ ./txt2c "$1"
+ else