summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mailutils-variable-lookup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mailutils-variable-lookup.patch')
-rw-r--r--gnu/packages/patches/mailutils-variable-lookup.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/mailutils-variable-lookup.patch b/gnu/packages/patches/mailutils-variable-lookup.patch
new file mode 100644
index 0000000000..0069f3596d
--- /dev/null
+++ b/gnu/packages/patches/mailutils-variable-lookup.patch
@@ -0,0 +1,26 @@
+Have 'send-message' look up 'mu-debug' & co. in the right
+module: <https://issues.guix.gnu.org/49968>.
+
+Submitted: https://lists.gnu.org/archive/html/bug-mailutils/2021-09/msg00000.html
+
+---
+ include/mailutils/guile.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/include/mailutils/guile.h b/include/mailutils/guile.h
+index f05550678..47f89db39 100644
+--- a/include/mailutils/guile.h
++++ b/include/mailutils/guile.h
+@@ -20,7 +20,8 @@
+
+ #include <libguile.h>
+
+-#define MU_SCM_SYMBOL_VALUE(p) SCM_VARIABLE_REF(scm_c_lookup(p))
++#define MU_SCM_SYMBOL_VALUE(p) \
++ (scm_c_public_ref ("mailutils mailutils", p))
+
+ typedef struct
+ {
+--
+2.33.0
+