summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libxml2-node-sort-order-pt1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libxml2-node-sort-order-pt1.patch')
-rw-r--r--gnu/packages/patches/libxml2-node-sort-order-pt1.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/libxml2-node-sort-order-pt1.patch b/gnu/packages/patches/libxml2-node-sort-order-pt1.patch
new file mode 100644
index 0000000000..181a0727ec
--- /dev/null
+++ b/gnu/packages/patches/libxml2-node-sort-order-pt1.patch
@@ -0,0 +1,33 @@
+From ba58f23c60862f2158b457f4d30031761bf4dde1 Mon Sep 17 00:00:00 2001
+From: Nick Wellnhofer <wellnhofer@aevum.de>
+Date: Sun, 8 Mar 2015 16:44:11 +0100
+Subject: [PATCH] Fix order of root nodes
+
+Make sure root nodes are sorted before other nodes.
+---
+ xpath.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/xpath.c b/xpath.c
+index ffd2a48..e9f5bf9 100644
+--- a/xpath.c
++++ b/xpath.c
+@@ -361,13 +361,13 @@ turtle_comparison:
+ /*
+ * compute depth to root
+ */
+- for (depth2 = 0, cur = node2;cur->parent != NULL;cur = cur->parent) {
++ for (depth2 = 0, cur = node2; cur != NULL; cur = cur->parent) {
+ if (cur == node1)
+ return(1);
+ depth2++;
+ }
+ root = cur;
+- for (depth1 = 0, cur = node1;cur->parent != NULL;cur = cur->parent) {
++ for (depth1 = 0, cur = node1; cur != NULL; cur = cur->parent) {
+ if (cur == node2)
+ return(-1);
+ depth1++;
+--
+2.6.3
+