summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libusb-for-axoloti.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libusb-for-axoloti.patch')
-rw-r--r--gnu/packages/patches/libusb-for-axoloti.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/libusb-for-axoloti.patch b/gnu/packages/patches/libusb-for-axoloti.patch
index 2c07d767d9..76a45e801d 100644
--- a/gnu/packages/patches/libusb-for-axoloti.patch
+++ b/gnu/packages/patches/libusb-for-axoloti.patch
@@ -1,14 +1,14 @@
-diff -rp -u4 libusb-1.0.19-orig/libusb/descriptor.c libusb-1.0.19/libusb/descriptor.c
---- libusb-1.0.19-orig/libusb/descriptor.c 2015-05-12 00:15:19 +0200
-+++ libusb-1.0.19/libusb/descriptor.c 2015-05-12 00:17:09 +0200
-@@ -1181,9 +1181,9 @@ int API_EXPORTED libusb_get_string_descr
+diff -rpu4 libusb-1.0.22.orig/libusb/descriptor.c libusb-1.0.22/libusb/descriptor.c
+--- libusb-1.0.22.orig/libusb/descriptor.c 2018-03-17 08:23:37.000000000 +0100
++++ libusb-1.0.22/libusb/descriptor.c 2018-03-29 10:36:09.968429473 +0200
+@@ -1173,9 +1173,9 @@ int API_EXPORTED libusb_get_string_descr
if (tbuf[1] != LIBUSB_DT_STRING)
return LIBUSB_ERROR_IO;
if (tbuf[0] > r)
- return LIBUSB_ERROR_IO;
-+ tbuf[0] = r;
++ tbuf[0] = r;
- for (di = 0, si = 2; si < tbuf[0]; si += 2) {
+ di = 0;
+ for (si = 2; si < tbuf[0]; si += 2) {
if (di >= (length - 1))
- break;