summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libtommath-fix-linkage.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libtommath-fix-linkage.patch')
-rw-r--r--gnu/packages/patches/libtommath-fix-linkage.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/patches/libtommath-fix-linkage.patch b/gnu/packages/patches/libtommath-fix-linkage.patch
new file mode 100644
index 0000000000..1a9d46eb7c
--- /dev/null
+++ b/gnu/packages/patches/libtommath-fix-linkage.patch
@@ -0,0 +1,55 @@
+https://github.com/libtom/libtommath/commit/93dea3a4162527346cd8856bfda6f17ffe98ab04.patch
+
+From 93dea3a4162527346cd8856bfda6f17ffe98ab04 Mon Sep 17 00:00:00 2001
+From: Steffen Jaeckel <s@jaeckel.eu>
+Date: Thu, 31 Jan 2019 14:12:03 +0100
+Subject: [PATCH] makefile.shared: fix compilation and linkage
+
+---
+ makefile.shared | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/makefile.shared b/makefile.shared
+index 3955f830..870b18d1 100644
+--- a/makefile.shared
++++ b/makefile.shared
+@@ -18,6 +18,7 @@ ifndef LIBTOOL
+ endif
+ endif
+ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC)
++LTLINK = $(LIBTOOL) --mode=link --tag=CC $(CC)
+
+ LCOV_ARGS=--directory .libs --directory .
+
+@@ -59,7 +60,7 @@ objs: $(OBJECTS)
+ LOBJECTS = $(OBJECTS:.o=.lo)
+
+ $(LIBNAME): $(OBJECTS)
+- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
++ $(LTLINK) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
+
+ install: $(LIBNAME)
+ install -d $(DESTDIR)$(LIBPATH)
+@@ -76,16 +77,16 @@ uninstall:
+ rm $(DESTDIR)$(LIBPATH)/pkgconfig/libtommath.pc
+
+ test: $(LIBNAME) demo/demo.o
+- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ test_standalone: $(LIBNAME) demo/demo.o
+- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
++ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ .PHONY: mtest
+ mtest:
+- cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
++ cd mtest ; $(CC) $(CFLAGS) -O0 mtest.c $(LDFLAGS) -o mtest
+
+ timing: $(LIBNAME) demo/timing.c
+- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
++ $(LTLINK) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing