summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libreoffice-boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libreoffice-boost.patch')
-rw-r--r--gnu/packages/patches/libreoffice-boost.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/libreoffice-boost.patch b/gnu/packages/patches/libreoffice-boost.patch
new file mode 100644
index 0000000000..b50664226b
--- /dev/null
+++ b/gnu/packages/patches/libreoffice-boost.patch
@@ -0,0 +1,17 @@
+Fix compatibility with newer Boost.
+
+Extracted from this upstream commit:
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
+
+diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
+--- a/sfx2/source/appl/shutdownicon.cxx
++++ b/sfx2/source/appl/shutdownicon.cxx
+@@ -144,7 +144,7 @@ bool LoadModule()
+ #endif // ENABLE_QUICKSTART_APPLET
+ }
+ assert(!boost::logic::indeterminate(loaded));
+- return loaded;
++ return bool(loaded);
+ }
+
+ }