summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libexpected-nofetch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libexpected-nofetch.patch')
-rw-r--r--gnu/packages/patches/libexpected-nofetch.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/libexpected-nofetch.patch b/gnu/packages/patches/libexpected-nofetch.patch
new file mode 100644
index 0000000000..e1d104f6f4
--- /dev/null
+++ b/gnu/packages/patches/libexpected-nofetch.patch
@@ -0,0 +1,27 @@
+Description: Disable FetchContent module
+ No online operations are permitted during build package.
+Author: Nicholas Guriev <guriev-ns@ya.ru>
+Last-Update: Wed, 22 Jan 2020 21:51:33 +0300
+
+Modified by Brett Gilio <brettg@gnu.org> on Dec 5, 2020
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,16 +4,7 @@ project(tl-expected VERSION 1.0.0 LANGUAGES CXX)
+
+ option(EXPECTED_ENABLE_TESTS "Enable tests." ON)
+
+-include(FetchContent)
+-FetchContent_Declare(
+- tl_cmake
+- GIT_REPOSITORY https://github.com/TartanLlama/tl-cmake.git
+-)
+-FetchContent_GetProperties(tl_cmake)
+-if(NOT tl_cmake_POPULATED)
+- FetchContent_Populate(tl_cmake)
+- set(CMAKE_MODULE_PATH ${tl_cmake_SOURCE_DIR} ${CMAKE_MODULE_PATH})
+-endif()
++set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/tl-cmake ${CMAKE_MODULE_PATH})
+ include(add-tl)
+
+ tl_add_library(expected SOURCES