summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lib2geom-fix-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/lib2geom-fix-tests.patch')
-rw-r--r--gnu/packages/patches/lib2geom-fix-tests.patch192
1 files changed, 0 insertions, 192 deletions
diff --git a/gnu/packages/patches/lib2geom-fix-tests.patch b/gnu/packages/patches/lib2geom-fix-tests.patch
deleted file mode 100644
index 47e8f6e2ec..0000000000
--- a/gnu/packages/patches/lib2geom-fix-tests.patch
+++ /dev/null
@@ -1,192 +0,0 @@
-From 3e858cc87f2f8b7dc514a8ad7709c1f47f1f4cde Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-Date: Wed, 17 Jun 2020 23:20:53 -0400
-Subject: [PATCH] tests: Fix tests on non-x86_64 platforms.
-
-On platform other than x86_64 such as aarch64-linux or i686-linux,
-some double comparisons would fail.
-
-See <http://issues.guix.gnu.org/41827>.
-
-* tests/bezier-test.cpp: (Casteljau): Replace EXPECT_EQ by
-EXPECT_near.
-(Subdivide): Replace EXPECT_EQ by EXPECT_DOUBLE_EQ.
-(Portion): Replace EXPECT_EQ by EXPECT_near.
-* tests/ellipse-test.cpp (BezierIntersection): Lower error tolerance
-from 6e-13 to 6e-12.
-(LineIntersection): Replace EXPECT_DOUBLE_EQ by EXPECT_NEAR.
-* tests/line-test.cpp (Reflection): Replace EXPECT_FLOAT_EQ BY
-EXPECT_near.
-(Coefficients): Skip test.
-* tests/parallelogram-test.cpp (area): Replace EXPECT_EQ by
-EXPECT_DOUBLE_EQ.
----
- tests/bezier-test.cpp | 31 +++++++++++++++++--------------
- tests/ellipse-test.cpp | 11 ++++++-----
- tests/line-test.cpp | 11 +++++++----
- tests/parallelogram-test.cpp | 8 ++++----
- 4 files changed, 34 insertions(+), 27 deletions(-)
-
-diff --git a/tests/bezier-test.cpp b/tests/bezier-test.cpp
-index 4054a654..46209f40 100644
---- a/tests/bezier-test.cpp
-+++ b/tests/bezier-test.cpp
-@@ -152,11 +152,13 @@ TEST_F(BezierTest, Casteljau) {
- EXPECT_vector_equal(right2, right);
-
- double vnone = casteljau_subdivision<double>(t, &wiggle[0], NULL, NULL, wiggle.order());
-- EXPECT_EQ(vnone, vok);
-+ EXPECT_near(vnone, vok, 1e-12);
- }
- }
-
- TEST_F(BezierTest, Portion) {
-+ constexpr Coord eps{1e-12};
-+
- for (unsigned i = 0; i < 10000; ++i) {
- double from = g_random_double_range(0, 1);
- double to = g_random_double_range(0, 1);
-@@ -165,8 +167,8 @@ TEST_F(BezierTest, Portion) {
- Bezier result = portion(input, from, to);
-
- // the endpoints must correspond exactly
-- EXPECT_EQ(result.at0(), input.valueAt(from));
-- EXPECT_EQ(result.at1(), input.valueAt(to));
-+ EXPECT_near(result.at0(), input.valueAt(from), eps);
-+ EXPECT_near(result.at1(), input.valueAt(to), eps);
- }
- }
- }
-@@ -181,16 +183,16 @@ TEST_F(BezierTest, Subdivide) {
-
- // the endpoints must correspond exactly
- // moreover, the subdivision point must be exactly equal to valueAt(t)
-- EXPECT_EQ(result.first.at0(), input.at0());
-- EXPECT_EQ(result.first.at1(), result.second.at0());
-- EXPECT_EQ(result.second.at0(), input.valueAt(t));
-- EXPECT_EQ(result.second.at1(), input.at1());
-+ EXPECT_DOUBLE_EQ(result.first.at0(), input.at0());
-+ EXPECT_DOUBLE_EQ(result.first.at1(), result.second.at0());
-+ EXPECT_DOUBLE_EQ(result.second.at0(), input.valueAt(t));
-+ EXPECT_DOUBLE_EQ(result.second.at1(), input.at1());
-
- // ditto for valueAt
-- EXPECT_EQ(result.first.valueAt(0), input.valueAt(0));
-- EXPECT_EQ(result.first.valueAt(1), result.second.valueAt(0));
-- EXPECT_EQ(result.second.valueAt(0), input.valueAt(t));
-- EXPECT_EQ(result.second.valueAt(1), input.valueAt(1));
-+ EXPECT_DOUBLE_EQ(result.first.valueAt(0), input.valueAt(0));
-+ EXPECT_DOUBLE_EQ(result.first.valueAt(1), result.second.valueAt(0));
-+ EXPECT_DOUBLE_EQ(result.second.valueAt(0), input.valueAt(t));
-+ EXPECT_DOUBLE_EQ(result.second.valueAt(1), input.valueAt(1));
-
- if (result.first.at1() != result.second.at0()) {
- errors.push_back(std::pair<Bezier,double>(input, t));
-@@ -271,9 +273,10 @@ TEST_F(BezierTest, Deflate) {
- EXPECT_FLOAT_EQ(0, b.at0());
- b = b.deflate();
- const double rootposition = (0.5-0.25) / (1-0.25);
-- EXPECT_FLOAT_EQ(0, b.valueAt(rootposition));
-+ constexpr Coord eps{1e-12};
-+ EXPECT_near(0.0, b.valueAt(rootposition), eps);
- b = b.subdivide(rootposition).second;
-- EXPECT_FLOAT_EQ(0, b.at0());
-+ EXPECT_near(0.0, b.at0(), eps);
- }
-
- TEST_F(BezierTest, Roots) {
-@@ -364,7 +367,7 @@ TEST_F(BezierTest, Operators) {
- for(int i = 0; i <= 16; i++) {
- double t = i/16.0;
- double b = B.valueAt(t);
-- EXPECT_FLOAT_EQ(b*b, product.valueAt(t));
-+ EXPECT_near(b*b, product.valueAt(t), 1e-12);
- }
- }
- }
-diff --git a/tests/ellipse-test.cpp b/tests/ellipse-test.cpp
-index 561c285a..8e4de12c 100644
---- a/tests/ellipse-test.cpp
-+++ b/tests/ellipse-test.cpp
-@@ -158,13 +158,14 @@ TEST(EllipseTest, LineIntersection) {
- std::vector<ShapeIntersection> xs = e.intersect(l);
-
- ASSERT_EQ(xs.size(), 2ul);
-- EXPECT_FLOAT_EQ(xs[0].point()[X], 0);
-- EXPECT_FLOAT_EQ(xs[0].point()[Y], -2);
-- EXPECT_FLOAT_EQ(xs[1].point()[X], 9./5);
-- EXPECT_FLOAT_EQ(xs[1].point()[Y], 8./5);
-
- // due to numeric imprecision when evaluating Ellipse,
- // the points may deviate by around 2e-16
-+ EXPECT_NEAR(xs[0].point()[X], 0, 1e-15);
-+ EXPECT_NEAR(xs[0].point()[Y], -2, 1e-15);
-+ EXPECT_NEAR(xs[1].point()[X], 9./5, 1e-15);
-+ EXPECT_NEAR(xs[1].point()[Y], 8./5, 1e-15);
-+
- EXPECT_intersections_valid(e, l, xs, 1e-15);
- }
-
-@@ -199,7 +200,7 @@ TEST(EllipseTest, BezierIntersection) {
- std::vector<ShapeIntersection> xs = e.intersect(b);
-
- EXPECT_EQ(xs.size(), 2ul);
-- EXPECT_intersections_valid(e, b, xs, 6e-13);
-+ EXPECT_intersections_valid(e, b, xs, 6e-12);
- }
-
- TEST(EllipseTest, Coefficients) {
-diff --git a/tests/line-test.cpp b/tests/line-test.cpp
-index 99546ddc..23991300 100644
---- a/tests/line-test.cpp
-+++ b/tests/line-test.cpp
-@@ -91,10 +91,12 @@ TEST(LineTest, Reflection) {
-
- Point testra = pa * reflecta;
- Point testrb = pb * reflectb;
-- EXPECT_FLOAT_EQ(testra[X], ra[X]);
-- EXPECT_FLOAT_EQ(testra[Y], ra[Y]);
-- EXPECT_FLOAT_EQ(testrb[X], rb[X]);
-- EXPECT_FLOAT_EQ(testrb[Y], rb[Y]);
-+
-+ constexpr Coord eps{1e-12};
-+ EXPECT_near(testra[X], ra[X], eps);
-+ EXPECT_near(testra[Y], ra[Y], eps);
-+ EXPECT_near(testrb[X], rb[X], eps);
-+ EXPECT_near(testrb[Y], rb[Y], eps);
- }
-
- TEST(LineTest, RotationToZero) {
-@@ -115,6 +117,7 @@ TEST(LineTest, RotationToZero) {
- }
-
- TEST(LineTest, Coefficients) {
-+ GTEST_SKIP() << "This test fails on i686-linux and aarch64-linux";
- std::vector<Line> lines;
- lines.push_back(Line(Point(1e9,1e9), Point(1,1)));
- //the case below will never work without normalizing the line
-diff --git a/tests/parallelogram-test.cpp b/tests/parallelogram-test.cpp
-index 8109eadd..70ccea13 100644
---- a/tests/parallelogram-test.cpp
-+++ b/tests/parallelogram-test.cpp
-@@ -106,13 +106,13 @@ TEST(ParallelogramTest, area)
- {
- Rect r(2, 4, 7, 8);
- Parallelogram p(r);
-- EXPECT_EQ(p.area(), r.area());
-+ EXPECT_DOUBLE_EQ(p.area(), r.area());
- p *= Rotate(M_PI / 4.0); // 45°
-- EXPECT_EQ(p.area(), r.area());
-+ EXPECT_DOUBLE_EQ(p.area(), r.area());
- p *= HShear(2);
-- EXPECT_EQ(p.area(), r.area());
-+ EXPECT_DOUBLE_EQ(p.area(), r.area());
- p *= Scale(2);
-- EXPECT_EQ(p.area(), r.area() * 4);
-+ EXPECT_DOUBLE_EQ(p.area(), r.area() * 4);
- }
-
- class ParallelogramTest
---
-2.27.0
-