summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/julia-allow-parallel-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/julia-allow-parallel-build.patch')
-rw-r--r--gnu/packages/patches/julia-allow-parallel-build.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/julia-allow-parallel-build.patch b/gnu/packages/patches/julia-allow-parallel-build.patch
new file mode 100644
index 0000000000..5a382e7c89
--- /dev/null
+++ b/gnu/packages/patches/julia-allow-parallel-build.patch
@@ -0,0 +1,30 @@
+diff --git a/test/runtests.jl b/test/runtests.jl
+index 2f9cd058bb..150395e78c 100644
+--- a/test/runtests.jl
++++ b/test/runtests.jl
+@@ -4,7 +4,7 @@ using Test
+ using Distributed
+ using Dates
+ import REPL
+-using Printf: @sprintf
++using Printf: @sprintf, @printf
+ using Base: Experimental
+
+ include("choosetests.jl")
+@@ -83,11 +83,15 @@ prepend!(tests, linalg_tests)
+ import LinearAlgebra
+ cd(@__DIR__) do
+ n = 1
+- if net_on
++ # Allow parallel tests with isolated environment
++ # https://github.com/JuliaLang/julia/issues/43205
++ # https://github.com/JuliaLang/julia/pull/43211
++ if net_on || haskey(ENV, "JULIA_CPU_THREADS")
+ n = min(Sys.CPU_THREADS, length(tests))
+ n > 1 && addprocs_with_testenv(n)
+ LinearAlgebra.BLAS.set_num_threads(1)
+ end
++ @printf("Number of threads: %i\n", n)
+ skipped = 0
+
+ @everywhere include("testdefs.jl")