summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/julia-0.3.10-fix-empty-array.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/julia-0.3.10-fix-empty-array.patch')
-rw-r--r--gnu/packages/patches/julia-0.3.10-fix-empty-array.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/julia-0.3.10-fix-empty-array.patch b/gnu/packages/patches/julia-0.3.10-fix-empty-array.patch
new file mode 100644
index 0000000000..b00f6549e3
--- /dev/null
+++ b/gnu/packages/patches/julia-0.3.10-fix-empty-array.patch
@@ -0,0 +1,13 @@
+See https://github.com/JuliaLang/julia/issues/11817
+
+--- a/src/codegen.cpp 2015-06-24 12:44:31.218674066 +0200
++++ b/src/codegen.cpp 2015-04-23 11:19:50.000000000 +0200
+@@ -4551,7 +4551,7 @@
+ #ifdef V128_BUG
+ "-avx",
+ #endif
+- };
++ ""};
+ SmallVector<std::string, 4> MAttrs(mattr, mattr+sizeof(mattr)/sizeof(mattr[0]));
+ EngineBuilder eb = EngineBuilder(engine_module)
+ .setEngineKind(EngineKind::JIT)