summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/higan-remove-march-native-flag.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/higan-remove-march-native-flag.patch')
-rw-r--r--gnu/packages/patches/higan-remove-march-native-flag.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/higan-remove-march-native-flag.patch b/gnu/packages/patches/higan-remove-march-native-flag.patch
new file mode 100644
index 0000000000..8f4a36dc35
--- /dev/null
+++ b/gnu/packages/patches/higan-remove-march-native-flag.patch
@@ -0,0 +1,13 @@
+Remove -march=native from build flags.
+
+--- a/higan/GNUmakefile
++++ b/higan/GNUmakefile
+@@ -32,7 +32,7 @@ ifeq ($(platform),windows)
+ else ifeq ($(platform),macosx)
+ flags += -march=native
+ else ifneq ($(filter $(platform),linux bsd),)
+- flags += -march=native -fopenmp
++ flags += -fopenmp
+ link += -fopenmp
+ link += -Wl,-export-dynamic
+ link += -lX11 -lXext