summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/go-fix-script-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/go-fix-script-tests.patch')
-rw-r--r--gnu/packages/patches/go-fix-script-tests.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/go-fix-script-tests.patch b/gnu/packages/patches/go-fix-script-tests.patch
new file mode 100644
index 0000000000..b29e83fef0
--- /dev/null
+++ b/gnu/packages/patches/go-fix-script-tests.patch
@@ -0,0 +1,18 @@
+Make library/header paths visible to cmd/go script tests, which is necessary for
+cgo/gccgo tests to work correctly
+
+diff --git a/src/cmd/go/script_test.go b/src/cmd/go/script_test.go
+index dfaa40548e..9d0f0e9bcd 100644
+--- a/src/cmd/go/script_test.go
++++ b/src/cmd/go/script_test.go
+@@ -100,6 +100,10 @@ const (
+ var extraEnvKeys = []string{
+ "SYSTEMROOT", // must be preserved on Windows to find DLLs; golang.org/issue/25210
+ "WINDIR", // must be preserved on Windows to be able to run PowerShell command; golang.org/issue/30711
++ "CPATH",
++ "C_INCLUDE_PATH",
++ "CPLUS_INCLUDE_PATH",
++ "LIBRARY_PATH",
+ "LD_LIBRARY_PATH", // must be preserved on Unix systems to find shared libraries
+ "CC", // don't lose user settings when invoking cgo
+ "GO_TESTING_GOTOOLS", // for gccgo testing