summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnome-todo-libical-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gnome-todo-libical-compat.patch')
-rw-r--r--gnu/packages/patches/gnome-todo-libical-compat.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnome-todo-libical-compat.patch b/gnu/packages/patches/gnome-todo-libical-compat.patch
new file mode 100644
index 0000000000..34f2e254b2
--- /dev/null
+++ b/gnu/packages/patches/gnome-todo-libical-compat.patch
@@ -0,0 +1,17 @@
+Fix compatibility with libical 3.0.
+
+Patch copied from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
+
+diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
+--- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 2017-11-08 14:53:53.484294926 +0100
++++ gnome-todo-3.26.2/src/gtd-task.c 2017-11-08 14:53:57.208294874 +0100
+@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask *task,
+ dt->minute = g_date_time_get_minute (now);
+ dt->second = g_date_time_get_seconds (now);
+ dt->is_date = 0;
+- dt->is_utc = 1;
++ dt->zone = icaltimezone_get_utc_timezone ();
+
+ /* convert timezone
+ *