summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gdbm-gcc-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gdbm-gcc-compat.patch')
-rw-r--r--gnu/packages/patches/gdbm-gcc-compat.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/gdbm-gcc-compat.patch b/gnu/packages/patches/gdbm-gcc-compat.patch
new file mode 100644
index 0000000000..c2e187834a
--- /dev/null
+++ b/gnu/packages/patches/gdbm-gcc-compat.patch
@@ -0,0 +1,16 @@
+Fix build failure with GCC 10 due to duplicate definitions. It can be
+reproduced on older compilers with -fno-common.
+
+Fix taken from Gentoo: https://bugs.gentoo.org/705898
+
+--- a/src/parseopt.c
++++ b/src/parseopt.c
+@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
+ }
+
+ char *parseopt_program_name;
+-char *parseopt_program_doc;
+-char *parseopt_program_args;
+ const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
+ void (*parseopt_help_hook) (FILE *stream);
+