summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ganeti-haskell-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ganeti-haskell-compat.patch')
-rw-r--r--gnu/packages/patches/ganeti-haskell-compat.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/ganeti-haskell-compat.patch b/gnu/packages/patches/ganeti-haskell-compat.patch
deleted file mode 100644
index 931c50e116..0000000000
--- a/gnu/packages/patches/ganeti-haskell-compat.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Adjust to type change of TupE in Template Haskell 2.16.
-
-diff --git a/src/Ganeti/THH/Types.hs b/src/Ganeti/THH/Types.hs
---- a/src/Ganeti/THH/Types.hs
-+++ b/src/Ganeti/THH/Types.hs
-@@ -123,4 +123,11 @@ curryN n = do
- f <- newName "f"
- ps <- replicateM n (newName "x")
- return $ LamE (VarP f : map VarP ps)
-- (AppE (VarE f) (TupE $ map VarE ps))
-+ (AppE (VarE f) (nonUnaryTupE $ map VarE ps))
-+ where
-+ nonUnaryTupE :: [Exp] -> Exp
-+ nonUnaryTupE es = TupE $
-+#if MIN_VERSION_template_haskell(2,16,0)
-+ map Just
-+#endif
-+ es