summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/docker-engine-test-noinstall.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/docker-engine-test-noinstall.patch')
-rw-r--r--gnu/packages/patches/docker-engine-test-noinstall.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/docker-engine-test-noinstall.patch b/gnu/packages/patches/docker-engine-test-noinstall.patch
new file mode 100644
index 0000000000..85d56a3465
--- /dev/null
+++ b/gnu/packages/patches/docker-engine-test-noinstall.patch
@@ -0,0 +1,23 @@
+Last-Update: 2018-06-18
+Forwarded: not-needed
+Author: Dmitry Smirnov <onlyjob@debian.org>
+Description: prevents test-time installation that causes FTBFS.
+~~~~
+ go test net: open /usr/lib/go-1.10/pkg/linux_amd64/net.a: permission denied
+~~~~
+
+--- a/hack/test/unit
++++ b/hack/test/unit
+@@ -18,12 +18,8 @@
+
+ exclude_paths="/vendor/|/integration"
+ pkg_list=$(go list $TESTDIRS | grep -vE "($exclude_paths)")
+
+-# install test dependencies once before running tests for each package. This
+-# significantly reduces the runtime.
+-go test -i "${BUILDFLAGS[@]}" $pkg_list
+-
+ for pkg in $pkg_list; do
+ go test "${BUILDFLAGS[@]}" \
+ -cover \
+ -coverprofile=profile.out \