summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/combinatorial-blas-io-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/combinatorial-blas-io-fix.patch')
-rw-r--r--gnu/packages/patches/combinatorial-blas-io-fix.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/combinatorial-blas-io-fix.patch b/gnu/packages/patches/combinatorial-blas-io-fix.patch
new file mode 100644
index 0000000000..0ad28e5e0b
--- /dev/null
+++ b/gnu/packages/patches/combinatorial-blas-io-fix.patch
@@ -0,0 +1,14 @@
+IO not appropriate in the context of a sorting routine, and in any case the
+proper headers are not included, so gcc emits an undefined symbol error.
+Remove the "printf" statement.
+
+--- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
++++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
+@@ -142,7 +142,6 @@
+ }
+ if ( (a[nmax]==a[nmin]) && (ctr==0) )
+ {
+- printf("All the numbers are identical, the list is sorted\n");
+ return;
+ }
+