summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clementine-use-openssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/clementine-use-openssl.patch')
-rw-r--r--gnu/packages/patches/clementine-use-openssl.patch67
1 files changed, 0 insertions, 67 deletions
diff --git a/gnu/packages/patches/clementine-use-openssl.patch b/gnu/packages/patches/clementine-use-openssl.patch
deleted file mode 100644
index 1fbf3d2b8a..0000000000
--- a/gnu/packages/patches/clementine-use-openssl.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4022c383b..3202b8b69 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -83,6 +83,7 @@ pkg_check_modules(LIBPULSE libpulse)
- pkg_check_modules(LIBXML libxml-2.0)
- pkg_check_modules(SPOTIFY libspotify>=12.1.45)
- pkg_check_modules(TAGLIB REQUIRED taglib>=1.6)
-+pkg_check_modules(OPENSSL REQUIRED openssl)
-
- if (WIN32)
- find_package(ZLIB REQUIRED)
-@@ -381,20 +382,6 @@ if(GMOCK_INCLUDE_DIRS)
- endif(GTEST_INCLUDE_DIRS)
- endif(GMOCK_INCLUDE_DIRS)
-
--# Use the system's sha2 if it's available.
--find_path(SHA2_INCLUDE_DIRS sha2.h)
--find_library(SHA2_LIBRARIES sha2)
--if(SHA2_LIBRARIES AND SHA2_INCLUDE_DIRS)
-- message(STATUS "Using system sha2 library")
-- set(USE_SYSTEM_SHA2 ON)
--else()
-- message(STATUS "Using builtin sha2 library")
-- set(USE_SYSTEM_SHA2 OFF)
-- add_subdirectory(3rdparty/sha2)
-- set(SHA2_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/sha2)
-- set(SHA2_LIBRARIES sha2)
--endif()
--
- # Use the system libmygpo-qt5 if a recent enough version was found
- if(LIBMYGPO_QT5_FOUND)
- set(MYGPOQT5_LIBRARIES ${LIBMYGPO_QT5_LIBRARIES})
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 6e24c9726..104d044d9 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -29,7 +29,6 @@ include_directories(${LIBPROJECTM_INCLUDE_DIRS})
- include_directories(${QTSINGLEAPPLICATION_INCLUDE_DIRS})
- include_directories(${QTIOCOMPRESSOR_INCLUDE_DIRS})
- include_directories(${QXT_INCLUDE_DIRS})
--include_directories(${SHA2_INCLUDE_DIRS})
- include_directories(${CHROMAPRINT_INCLUDE_DIRS})
- include_directories(${MYGPOQT5_INCLUDE_DIRS})
-
-@@ -1223,7 +1222,7 @@ target_link_libraries(clementine_lib
- libclementine-common
- libclementine-tagreader
- libclementine-remote
-- ${SHA2_LIBRARIES}
-+ ${OPENSSL_LIBRARIES}
- ${TAGLIB_LIBRARIES}
- ${MYGPOQT5_LIBRARIES}
- ${CHROMAPRINT_LIBRARIES}
-diff --git a/src/core/utilities.cpp b/src/core/utilities.cpp
-index ce76f22da..80bf623fb 100644
---- a/src/core/utilities.cpp
-+++ b/src/core/utilities.cpp
-@@ -52,7 +52,7 @@
- #include "config.h"
- #include "timeconstants.h"
-
--#include "sha2.h"
-+#include <openssl/sha.h>
-
- #if defined(Q_OS_UNIX)
- #include <sys/statvfs.h>