summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch')
-rw-r--r--gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch b/gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch
new file mode 100644
index 0000000000..00e0f3c4a3
--- /dev/null
+++ b/gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch
@@ -0,0 +1,54 @@
+Based on (hunks for changelog and Identy.cpp removed)
+From ecbc07f0ed336187cc9a67c3363f89681b8b8f52 Mon Sep 17 00:00:00 2001
+From: Michael Pruett <michael@68k.org>
+Date: Tue, 5 Jul 2016 23:26:16 -0500
+Subject: [PATCH] Fix type of test data arrays.
+
+
+
+
+---
+ ChangeLog | 6 ++++++
+ test/Identify.cpp | 3 ++-
+ test/NeXT.cpp | 7 ++++---
+ 3 files changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/test/NeXT.cpp b/test/NeXT.cpp
+index 7e39850..29af877 100644
+--- a/test/NeXT.cpp
++++ b/test/NeXT.cpp
+@@ -30,6 +30,7 @@
+ #include <audiofile.h>
+ #include <fcntl.h>
+ #include <gtest/gtest.h>
++#include <stdint.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+@@ -37,7 +38,7 @@
+
+ #include "TestUtilities.h"
+
+-const char kDataUnspecifiedLength[] =
++const uint8_t kDataUnspecifiedLength[] =
+ {
+ '.', 's', 'n', 'd',
+ 0, 0, 0, 24, // offset of 24 bytes
+@@ -57,7 +58,7 @@ const char kDataUnspecifiedLength[] =
+ 0, 55
+ };
+
+-const char kDataTruncated[] =
++const uint8_t kDataTruncated[] =
+ {
+ '.', 's', 'n', 'd',
+ 0, 0, 0, 24, // offset of 24 bytes
+@@ -152,7 +153,7 @@ TEST(NeXT, Truncated)
+ ASSERT_EQ(::unlink(testFileName.c_str()), 0);
+ }
+
+-const char kDataZeroChannels[] =
++const uint8_t kDataZeroChannels[] =
+ {
+ '.', 's', 'n', 'd',
+ 0, 0, 0, 24, // offset of 24 bytes