summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm54
1 files changed, 46 insertions, 8 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f83c05a25b..46b6e795ab 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -9,13 +9,14 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,8 @@
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -89,7 +92,7 @@ human.")
(define-public keepassxc
(package
(name "keepassxc")
- (version "2.2.4")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
@@ -98,10 +101,17 @@ human.")
version "-src.tar.xz"))
(sha256
(base32
- "1pfkq1m5vb90kx67vyw70s1hc4ivjsvq2535vm6wdwwsncna6bz5"))))
+ "1gdrbpzwbs56anc3k5vklvcackcn214pc8gm5xh5zcymsi8q4zff"))))
(build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DWITH_XC_NETWORKING=YES"
+ "-DWITH_XC_BROWSER=YES"
+ "-DWITH_XC_SSHAGENT=YES")))
(inputs
- `(("libgcrypt" ,libgcrypt)
+ `(("argon2" ,argon2)
+ ("curl" ,curl) ; XC_NETWORKING
+ ("libgcrypt" ,libgcrypt)
+ ("libsodium" ,libsodium) ; XC_BROWSER
("libxi" ,libxi)
("libxtst" ,libxtst)
("qtbase" ,qtbase)
@@ -190,7 +200,7 @@ applications, there is xclip integration." )
(define-public yapet
(package
(name "yapet")
- (version "1.0")
+ (version "1.1")
(source (origin
(method url-fetch)
(uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
@@ -198,7 +208,7 @@ applications, there is xclip integration." )
".tar.bz2"))
(sha256
(base32
- "0ydbnqw6icdh07pnv2w6dhvq501bdfvrklv4xmyr8znca9d753if"))))
+ "1lq46mpxdsbl6qw4cj58hp9q7jckmyvbsi08p5zr77rjgqadxyyy"))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)
@@ -271,7 +281,7 @@ random passwords that pass the checks.")
(define-public assword
(package
(name "assword")
- (version "0.10")
+ (version "0.11")
(source (origin
(method url-fetch)
(uri (list
@@ -280,7 +290,7 @@ random passwords that pass the checks.")
"assword_" version ".orig.tar.gz")))
(sha256
(base32
- "0l6170y6my1gprqkazvzabgjkrkr9v2q7z48vjflna4r323yqira"))))
+ "03gkb6kvsghznbcw5l7nmrc6mn3ixkjd5jcs96ni4zs9l47jf7yp"))))
(arguments
`(;; irritatingly, tests do run but not there are two problems:
;; - "import gtk" fails for unknown reasons here despite it the
@@ -603,3 +613,31 @@ password hash types most commonly found on various Unix systems, supported out
of the box are Windows LM hashes, plus lots of other hashes and ciphers. This
is the community-enhanced, \"jumbo\" version of John the Ripper.")
(license license:gpl2+))))
+
+(define-public sala
+ (package
+ (name "sala")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sala" version))
+ (sha256
+ (base32
+ "13qgmc3i2a0cqp8jqrfl93lnphfagb32pgfikc1gza2a14asxzi8"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Sala is supposed to work with Python 3.2 or higher,
+ ;; but it doesn't work with Python 3.6. Better stick
+ ;; to Python 2, which works fine.
+ `(#:python ,python-2))
+ (propagated-inputs
+ `(("gnupg" ,gnupg)
+ ("pwgen" ,pwgen)))
+ (home-page "http://www.digip.org/sala/")
+ (synopsis "Encrypted plaintext password store")
+ (description
+ "Store passwords and other bits of sensitive plain-text information
+to encrypted files on a directory hierarchy. The information is protected
+by GnuPG's symmetrical encryption.")
+ (license license:expat)))