summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index dd4eeba0ac..dd24808a7e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -114,7 +114,7 @@ human.")
(define-public keepassxc
(package
(name "keepassxc")
- (version "2.5.0")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
@@ -123,7 +123,7 @@ human.")
version "-src.tar.xz"))
(sha256
(base32
- "10bq2934xqpjpr99wbjg2vwmi73fcq0419cb3v78n2kj5fbwwnb3"))))
+ "0c5g5hn2cr2m00xgpxg884ihy8gnn09kc487y1m9jywshn5jaczg"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DWITH_XC_ALL=YES"
@@ -294,21 +294,22 @@ applications, there is xclip integration." )
(define-public yapet
(package
(name "yapet")
- (version "1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "1lq46mpxdsbl6qw4cj58hp9q7jckmyvbsi08p5zr77rjgqadxyyy"))))
+ (version "2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://yapet.guengel.ch/downloads/yapet-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1fl4s7v1psl52ndd6i7716i9f493aj8ipl6lgmraadnn5h26l3pm"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)
+ `(("argon2" ,argon2)
+ ("ncurses" ,ncurses)
("openssl" ,openssl)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
(synopsis "Yet Another Password Encryption Tool")
(description "YAPET is a text based password manager using the Blowfish
encryption algorithm. Because of its small footprint and very few library
@@ -353,19 +354,19 @@ them out, at the source.")
(define-public libpwquality
(package
(name "libpwquality")
- (version "1.4.0")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (list
- (string-append "https://github.com/" name "/" name
- "/releases/download/" name "-" version
- "/" name "-" version ".tar.bz2")
+ (string-append "https://github.com/libpwquality/libpwquality"
+ "/releases/download/libpwquality-" version
+ "/libpwquality-" version ".tar.bz2")
(string-append "https://launchpad.net/libpwquality/trunk/"
version "/+download/"
- name "-" version ".tar.bz2")))
+ "libpwquality-" version ".tar.bz2")))
(sha256
(base32
- "0syyz8r54l8mqmbb0mw19qz4z2cx8gdgidicb8k2s5zjdh2gzrhx"))))
+ "13hw532fmzc5xjpy75d74rlfdlxf2a8ibb4hyy9c0s92wsgf0qsj"))))
(build-system gnu-build-system)
(arguments
;; XXX: have RUNPATH issue.