summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 55c14762e9..f8111b2abf 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,8 +34,8 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
- #:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
@@ -216,7 +217,7 @@ random passwords that pass the checks.")
(define-public assword
(package
(name "assword")
- (version "0.8")
+ (version "0.10")
(source (origin
(method url-fetch)
(uri (list
@@ -225,10 +226,9 @@ random passwords that pass the checks.")
"assword_" version ".orig.tar.gz")))
(sha256
(base32
- "0dl4wizbi0r21wxzykm8s445xbvqim5nabi799dmpkdnnh8i546i"))))
+ "0l6170y6my1gprqkazvzabgjkrkr9v2q7z48vjflna4r323yqira"))))
(arguments
- `(#:python ,python-2
- ;; irritatingly, tests do run but not there are two problems:
+ `(;; irritatingly, tests do run but not there are two problems:
;; - "import gtk" fails for unknown reasons here despite it the
;; program working (indeed, I've found I have to do a logout and log
;; back in in after an install order for some mumbo jumbo environment
@@ -242,18 +242,21 @@ random passwords that pass the checks.")
(add-after 'install 'manpage
(lambda* (#:key outputs #:allow-other-keys)
(and
+ ;; Without this substitution, it fails with
+ ;; ImportError: No module named 'gpg'
+ (substitute* "Makefile"
+ (("PYTHONPATH=.") ""))
(zero? (system* "make" "assword.1"))
(install-file
"assword.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))))))))
(build-system python-build-system)
(native-inputs
- `(("help2man" ,help2man)))
+ `(("txt2man" ,txt2man)))
(inputs
- `(("python-setuptools" ,python2-setuptools)
- ("python2-xdo" ,python2-xdo)
- ("python2-pygpgme" ,python2-pygpgme)
- ("python2-pygtk" ,python2-pygtk)))
+ `(("python-xdo" ,python-xdo)
+ ("python-gpg" ,python-gpg)
+ ("python-pygobject" ,python-pygobject)))
(propagated-inputs
`(("xclip" ,xclip)))
(home-page "https://finestructure.net/assword/")
@@ -281,6 +284,7 @@ any X11 window.")
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (delete 'build)
(add-after 'install 'wrap-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -291,6 +295,9 @@ any X11 window.")
(wrap-program (string-append out "/bin/pass")
`("PATH" ":" prefix (,(string-join path ":"))))))))
#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+ ;; Parallel tests may cause a race condition leading to a
+ ;; timeout in some circumstances.
+ #:parallel-tests? #f
#:test-target "test"))
(inputs
`(("getopt" ,util-linux)
@@ -314,18 +321,17 @@ through the pass command.")
(define-public argon2
(package
(name "argon2")
- (version "20160406")
+ (version "20161029")
(source
(origin
(method url-fetch)
(uri
- (string-append
- "https://codeload.github.com/P-H-C/phc-winner-"
- name "/tar.gz/" version))
+ (string-append "https://github.com/P-H-C/phc-winner-argon2/archive/"
+ version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0g6wa94sh639xl1qc8z21q43r1mp8y77r1zf8nwx5pfsxd8fmyzv"))))
+ "1rymikbysasdadm325jx69i0q19d9srqkny69jwmhswlidr4j07y"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -362,7 +368,7 @@ winner of the 2015 Password Hashing Competition.")
(native-inputs
`(("python-pycparser" ,python-pycparser)
("python-pytest" ,python-pytest)))
- (inputs
+ (propagated-inputs
`(("python-cffi" ,python-cffi)
("python-six" ,python-six)))
(home-page "https://github.com/pyca/bcrypt/")
@@ -376,8 +382,4 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(license license:asl2.0)))
(define-public python2-bcrypt
- (let ((bcrypt (package-with-python2 python-bcrypt)))
- (package (inherit bcrypt)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs bcrypt))))))
+ (package-with-python2 python-bcrypt))