summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm46
1 files changed, 42 insertions, 4 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f6af6a6519..08591d1086 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -9,6 +9,8 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +38,7 @@
#:use-module (gnu packages aidc)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
@@ -186,14 +189,15 @@ and vice versa.")
(home-page "https://github.com/cracklib/cracklib")
(description
"CrackLib is a library containing a C function which may be used in a
-passwd like program. The idea is simple: try to prevent users from choosing
-passwords that could be guessed by crack by filtering them out, at source.")
+@command{passwd}-like program. The idea is simple: try to prevent users from
+choosing passwords that could easily be guessed (or \"cracked\") by filtering
+them out, at the source.")
(license license:lgpl2.1)))
(define-public libpwquality
(package
(name "libpwquality")
- (version "1.3.0")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (list
@@ -205,7 +209,7 @@ passwords that could be guessed by crack by filtering them out, at source.")
name "-" version ".tar.bz2")))
(sha256
(base32
- "0aidriag6h0syfm33nzdfdsqgrnsgihwjv3a5lgkqch3w68fmlkl"))))
+ "0syyz8r54l8mqmbb0mw19qz4z2cx8gdgidicb8k2s5zjdh2gzrhx"))))
(build-system gnu-build-system)
(arguments
;; XXX: have RUNPATH issue.
@@ -408,3 +412,37 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(define-public python2-bcrypt
(package-with-python2 python-bcrypt))
+
+(define-public pass-git-helper
+ (package
+ (name "pass-git-helper")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/languitar/pass-git-helper/archive/release-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lz5ncy44pz7z1j2nnyildx8sq33zi3xvg5nkwg25n11nasqh2xn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-pass-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((password-store (assoc-ref inputs "password-store"))
+ (pass (string-append password-store "/bin/pass")))
+ (substitute* "pass-git-helper"
+ (("'pass'") (string-append "'" pass "'")))
+ #t))))))
+ (inputs
+ `(("python-pyxdg" ,python-pyxdg)
+ ("password-store" ,password-store)))
+ (home-page "https://github.com/languitar/pass-git-helper")
+ (synopsis "Git credential helper interfacing with pass")
+ (description "pass-git-helper is a git credential helper which allows to
+use pass, the standard unix password manager, as the credential backend for
+your git repositories. This is achieved by explicitly defining mappings
+between hosts and entries in the password store.")
+ (license license:lgpl3+)))