summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm94
1 files changed, 91 insertions, 3 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 42826f49d6..8f5d0aeb64 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
@@ -31,6 +31,7 @@
(define-module (gnu packages parallel)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,9 +42,11 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages flex)
#:use-module (gnu packages freeipmi)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -58,14 +61,14 @@
(define-public parallel
(package
(name "parallel")
- (version "20210622")
+ (version "20210722")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/parallel/parallel-"
version ".tar.bz2"))
(sha256
- (base32 "11pcc5kim104wz25k5q1pqhd6z85d7dx509h74ncaxhyyydjfcvv"))))
+ (base32 "0jaa5137sjw2szvmnnslkqv1n3gg2rkkgr71j7hpp5a3q15hjf9j"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -378,3 +381,88 @@ and output captured in the notebook. Whatever arguments are accepted by a
SLURM command line executable are also accepted by the corresponding magic
command---e.g., @code{%salloc}, @code{%sbatch}, etc.")
(license license:bsd-3))))
+
+(define-public pthreadpool
+ ;; This repository has only one tag, 0.1, which is older than what users
+ ;; such as XNNPACK expect.
+ (let ((commit "1787867f6183f056420e532eec640cba25efafea")
+ (version "0.1")
+ (revision "1"))
+ (package
+ (name "pthreadpool")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/Maratyszcza/pthreadpool")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02hdvxfn5krw8zivkgjx3b4rk9p02yr4mpdjlp75lsv6z1xf5yrx"))
+ (patches (search-patches "pthreadpool-system-libraries.patch"))))
+ (build-system cmake-build-system)
+ (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ (inputs
+ `(("googletest" ,googletest)
+ ("googlebenchmark" ,googlebenchmark)
+ ("fxdiv" ,fxdiv)))
+ (synopsis "Efficient thread pool implementation")
+ (description
+ "The pthreadpool library implements an efficient and portable thread
+pool, similar to those implemented by OpenMP run-time support libraries for
+constructs such as @code{#pragma omp parallel for}, with additional
+features.")
+ (license license:bsd-2))))
+
+(define-public cpuinfo
+ ;; There's currently no tag on this repo.
+ (let ((version "0.0")
+ (revision "1")
+ (commit "866ae6e5ffe93a1f63be738078da94cf3005cce2"))
+ (package
+ (name "cpuinfo")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/pytorch/cpuinfo")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lmsf4bpkm19a31i40qwcjn46qf7prggziv4pbsi695bkx5as71p"))
+ (patches (search-patches "cpuinfo-system-libraries.patch"))))
+ (build-system cmake-build-system)
+ (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ (inputs
+ `(("googletest" ,googletest)
+ ("googlebenchmark" ,googlebenchmark)))
+ (synopsis "C/C++ library to obtain information about the CPU")
+ (description
+ "The cpuinfo library provides a C/C++ and a command-line interface to
+obtain information about the CPU being used: supported instruction set,
+processor name, cache information, and topology information.")
+ (license license:bsd-2))))
+
+(define-public psimd
+ ;; There is currently no tag in this repo.
+ (let ((commit "072586a71b55b7f8c584153d223e95687148a900")
+ (version "0.0")
+ (revision "1"))
+ (package
+ (name "psimd")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/Maratyszcza/Psimd")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16mslhvqs0gpqbg7kkq566a8gkn58cgjpqca8ljj9qcv5mk9apwm"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;there are no tests
+ (synopsis "Portable 128-bit SIMD intrinsics")
+ (description
+ "This header-only C++ library provides a portable interface to
+single-instruction multiple-data (SIMD) intrinsics.")
+ (license license:expat))))