summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c1e6657dff..bfecf110ca 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -118,8 +118,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.1.0")
- (commit "141b5c162048f5cb52e8c90ff7c16a2e98babcfb")
- (revision 10))
+ (commit "c00564192a9924ab2218c243342963aba89d67d1")
+ (revision 12))
(package
(name "guix")
@@ -135,7 +135,7 @@
(commit commit)))
(sha256
(base32
- "1j3vag994kj05b09a7w4lyas991a19hbbslcm9xvn5k2ilf4qskz"))
+ "008ywpdkc5f2jh25x6rr9glzvq4a6qih7v73w5dbxscpddx5c5g2"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -319,7 +319,7 @@ $(prefix)/etc/init.d\n")))
;; Guile libraries are needed here for
;; cross-compilation.
- ("guile" ,guile-3.0)
+ ("guile" ,guile-3.0-latest) ;for faster builds
("gnutls" ,gnutls)
("guile-gcrypt" ,guile-gcrypt)
("guile-json" ,guile-json-4)
@@ -346,7 +346,7 @@ $(prefix)/etc/init.d\n")))
("sqlite" ,sqlite)
("libgcrypt" ,libgcrypt)
- ("guile" ,guile-3.0)
+ ("guile" ,guile-3.0-latest)
;; Some of the tests use "unshare" when it is available.
("util-linux" ,util-linux)
@@ -542,15 +542,30 @@ out) and returning a package that uses that as its 'source'."
(define-public nix
(package
(name "nix")
- (version "2.3.5")
+ (version "2.3.6")
(source (origin
(method url-fetch)
(uri (string-append "http://nixos.org/releases/nix/nix-"
version "/nix-" version ".tar.xz"))
(sha256
(base32
- "1hbqsrp1ii2sfq8x2mahjrl2182qck76n8blrl1jfz3xq99m6i15"))))
+ "128xf2as0y7hr28x575pbf9lkjpxr9hsxknbavv4p7ywr4lhbs85"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ ;; Don't try & fail to create subdirectories in /etc, but keep them
+ ;; in the output as examples.
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" etc)
+ (string-append "profiledir=" etc "/profile.d")
+ make-flags)))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("boost" ,boost)
("brotli" ,brotli)
@@ -882,7 +897,7 @@ written entirely in Python.")))
("texinfo" ,texinfo)
("graphviz" ,graphviz)))
(inputs
- `(("guile" ,guile-3.0)))
+ `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
(propagated-inputs
`(("guix" ,guix)
("guile-commonmark" ,guile-commonmark)
@@ -980,7 +995,7 @@ environments.")
("python-ipykernel" ,python-ipykernel)))
(inputs
`(("guix" ,guix)
- ("guile" ,guile-3.0)))
+ ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
(propagated-inputs
`(("guile-json" ,guile-json-4)
("guile-simple-zmq" ,guile-simple-zmq)
@@ -1137,7 +1152,9 @@ the boot loader configuration.")
(string-append "--with-system-bubblewrap="
(assoc-ref %build-inputs "bubblewrap")
"/bin/bwrap")
- "--with-system-dbus-proxy")
+ (string-append "--with-system-dbus-proxy="
+ (assoc-ref %build-inputs "xdg-dbus-proxy")
+ "/bin/xdg-dbus-proxy"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-tests