summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 8130097c83..d41c9c8916 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -271,10 +271,16 @@ tested on Python version 3.2, 2.7 and 2.6.")
(description
"This module provides a building block to stub out the HTTP requests
portions of your testing code.")
+ (properties `((python2-variant . ,(delay python2-requests-mock))))
(license asl2.0)))
(define-public python2-requests-mock
- (package-with-python2 python-requests-mock))
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-requests-mock)))
+ (arguments
+ `(#:python ,python-2
+ ;; FIXME: 'subunit.run discover: error: no such option: --list'
+ #:tests? #f))))
(define-public python-stevedore
(package