summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm57
1 files changed, 23 insertions, 34 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 13b92936d0..17a4f3dcdb 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -212,9 +212,6 @@ Google mox framework} to Python 3. It was meant to be as compatible
with mox as possible, but small enhancements have been made.")
(license asl2.0)))
-(define-public python2-mox3
- (package-with-python2 python-mox3))
-
(define-public python-openstackdocstheme
(package
(name "python-openstackdocstheme")
@@ -242,9 +239,6 @@ with mox as possible, but small enhancements have been made.")
to docs.openstack.org and developer.openstack.org.")
(license asl2.0)))
-(define-public python2-openstackdocstheme
- (package-with-python2 python-openstackdocstheme))
-
(define-public python-os-client-config
(package
(name "python-os-client-config")
@@ -390,7 +384,11 @@ extensions.")
common features used in Tempest.")
(license asl2.0)))
-;; Packages from the Oslo library
+
+;;;
+;;; Packages from the Oslo library
+;;;
+
(define-public python-oslo.config
(package
(name "python-oslo.config")
@@ -400,8 +398,8 @@ common features used in Tempest.")
(method url-fetch)
(uri (pypi-uri "oslo.config" version))
(sha256
- (base32
- "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
+ (base32
+ "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
(build-system python-build-system)
(propagated-inputs
`(("python-debtcollector" ,python-debtcollector)
@@ -426,7 +424,7 @@ common features used in Tempest.")
(home-page "https://launchpad.net/oslo")
(synopsis "Oslo Configuration API")
(description
- "The Oslo configuration API supports parsing command line arguments and
+ "The Oslo configuration API supports parsing command line arguments and
.ini style configuration files.")
(license asl2.0)))
@@ -468,42 +466,36 @@ about a request context. The request context is usually populated in the WSGI
pipeline and used by various modules such as logging.")
(license asl2.0)))
-(define-public python2-oslo.context
- (package-with-python2 python-oslo.context))
-
(define-public python-oslo.i18n
(package
(name "python-oslo.i18n")
(version "3.20.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "oslo.i18n" version))
- (sha256
- (base32
- "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "oslo.i18n" version))
+ (sha256
+ (base32
+ "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-babel" ,python-babel)
- ("python-six" ,python-six)))
+ `(("python-babel" ,python-babel)
+ ("python-six" ,python-six)))
(native-inputs
- `(("python-pbr" ,python-pbr)
- ;; Tests
- ("python-mock" ,python-mock)
- ("python-mox3" ,python-mox3)
- ("python-oslotest" ,python-oslotest)
- ("python-testscenarios" ,python-testscenarios)))
+ `(("python-pbr" ,python-pbr)
+ ;; Tests
+ ("python-mock" ,python-mock)
+ ("python-mox3" ,python-mox3)
+ ("python-oslotest" ,python-oslotest)
+ ("python-testscenarios" ,python-testscenarios)))
(home-page "https://launchpad.net/oslo")
(synopsis "Oslo internationalization (i18n) library")
(description
- "The oslo.i18n library contain utilities for working with
+ "The oslo.i18n library contain utilities for working with
internationalization (i18n) features, especially translation for text strings
in an application or library.")
(license asl2.0)))
-(define-public python2-oslo.i18n
- (package-with-python2 python-oslo.i18n))
-
(define-public python-oslo.log
(package
(name "python-oslo.log")
@@ -611,9 +603,6 @@ in transmittable and storable formats, such as JSON and MessagePack.")
and building documentation from them.")
(license asl2.0)))
-(define-public python2-reno
- (package-with-python2 python-reno))
-
(define-public python-oslosphinx
(package
(name "python-oslosphinx")