summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 12964e302a..850223cd4c 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -84,11 +84,9 @@
(native-inputs `(("libtool" ,libtool)))
(arguments
`(#:tests? #f
+ #:configure-flags '("--disable-static")
#:phases
(modify-phases %standard-phases
- (add-after 'configure 'provide-libtool
- (lambda _ (copy-file (which "libtool") "libtool")
- #t))
(add-after 'install 'patch-sasl-path
;; Give -L arguments for cyrus-sasl to avoid propagation.
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -108,14 +106,14 @@
(define-public nss-pam-ldapd
(package
(name "nss-pam-ldapd")
- (version "0.9.9")
+ (version "0.9.10")
(source (origin
(method url-fetch)
(uri (string-append "https://arthurdejong.org/nss-pam-ldapd/"
"nss-pam-ldapd-" version ".tar.gz"))
(sha256
(base32
- "1lj7qkjlg3bshwdc5x5r1ny37rly4wgm1c8b6w6b5f4wa11nmji0"))))
+ "1cqamcr6qpgwxijlr6kg7jspjamjra8w0haan0qssn0yxn95d7c0"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -295,6 +293,7 @@ servers from Python programs.")
("nspr" ,nspr)
("nss" ,nss)
("openldap" ,openldap)
+ ("openssl" ,openssl) ; #included by net-snmp
("pcre" ,pcre)
("perl" ,perl)
("python" ,python)