summaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 0bcc885c39..5353846ece 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -43,11 +43,19 @@
(modify-phases %standard-phases
(add-after 'unpack 'remote-dangling-symlink
(lambda _
+ (substitute* '("man/netconfig.5"
+ "man/getnetconfig.3t"
+ "man/getnetpath.3t"
+ "man/rpc.3t"
+ "src/getnetconfig.c"
+ "tirpc/netconfig.h")
+ (("/etc/netconfig") (string-append %output "/etc/netconfig")))
+
;; Remove the dangling symlinks since it breaks the
;; 'patch-source-shebangs' file tree traversal.
(delete-file "INSTALL"))))))
(inputs `(("mit-krb5" ,mit-krb5)))
- (home-page "http://sourceforge.net/projects/libtirpc/")
+ (home-page "https://sourceforge.net/projects/libtirpc/")
(synopsis "Transport-independent Sun/ONC RPC implementation")
(description
"This package provides a library that implements the Sun/ONC RPC (remote