summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm87
1 files changed, 46 insertions, 41 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d9ba2aee2d..1b40063ffb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -238,7 +238,7 @@ functional, imperative and object-oriented styles of programming.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml/ocamlbuild.git")
+ (url "https://github.com/ocaml/ocamlbuild")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -533,7 +533,7 @@ Git-friendly development workflow.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/camlp5/camlp5.git")
+ (url "https://github.com/camlp5/camlp5")
(commit (string-append "rel" (string-delete #\. version)))))
(file-name (git-file-name name version))
(sha256
@@ -620,7 +620,7 @@ written in Objective Caml.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml/num.git")
+ (url "https://github.com/ocaml/num")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -666,7 +666,7 @@ the OCaml core distribution.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml/tuareg.git")
+ (url "https://github.com/ocaml/tuareg")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -843,7 +843,7 @@ libpanel, librsvg and quartz.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/bcpierce00/unison.git")
+ (url "https://github.com/bcpierce00/unison")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1156,7 +1156,7 @@ GNU CC attributes. It provides also a C pretty printer as an example of use.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/c-cube/qcheck.git")
+ (url "https://github.com/c-cube/qcheck")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1683,7 +1683,7 @@ simple (yet expressive) query language to select the tests to run.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/alainfrisch/ppx_tools.git")
+ (url "https://github.com/alainfrisch/ppx_tools")
(commit version)))
(file-name (git-file-name name version))
(sha256 (base32
@@ -1738,7 +1738,7 @@ lets the client choose the concrete timeline.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/savonet/ocaml-ssl.git")
+ (url "https://github.com/savonet/ocaml-ssl")
(commit version)))
(file-name (git-file-name name version))
(sha256 (base32
@@ -2575,7 +2575,7 @@ programs. It allows the definition of simple macros and file inclusion. Cpp oi
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/c-cube/seq.git")
+ (url "https://github.com/c-cube/seq")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -2613,7 +2613,7 @@ standard iterator type starting from 4.07.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml/ocaml-re.git")
+ (url "https://github.com/ocaml/ocaml-re")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -2722,7 +2722,7 @@ writing to these structures, and they are accessed via the Bigarray module.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mirage/ezjsonm.git")
+ (url "https://github.com/mirage/ezjsonm")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2755,7 +2755,7 @@ JSON.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mirage/ocaml-uri.git")
+ (url "https://github.com/mirage/ocaml-uri")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2822,7 +2822,7 @@ Format module of the OCaml standard library.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/alavrik/piqi.git")
+ (url "https://github.com/alavrik/piqi")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2940,13 +2940,14 @@ and 4 (random based) according to RFC 4122.")
(name "ocaml4.07-piqi")
(version "0.7.7")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/alavrik/piqi-ocaml/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alavrik/piqi-ocaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1l0b4saxmwqgw9mb10mwrz31lvpj3l0abh3cwarqp0x4vdrzshbh"))))
+ "1913jpsb8mvqi8609j4g4sm5jhg50dq0xqxgy8nmvknfryyc89nm"))))
(build-system ocaml-build-system)
(arguments
`(#:make-flags
@@ -2955,6 +2956,10 @@ and 4 (random based) according to RFC 4122.")
"/bin/sh"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-files-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
(delete 'configure))
#:ocaml ,ocaml-4.07
#:findlib ,ocaml4.07-findlib))
@@ -3115,7 +3120,7 @@ function that follows the prototype of POSIX's wcwidth.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/diml/zed.git")
+ (url "https://github.com/diml/zed")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -3145,7 +3150,7 @@ connect an engine to your inputs and rendering functions to get an editor.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/diml/lambda-term.git")
+ (url "https://github.com/diml/lambda-term")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -3181,7 +3186,7 @@ instead of bindings to a C library.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml-community/utop.git")
+ (url "https://github.com/ocaml-community/utop")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -3372,7 +3377,7 @@ cross-platform SDL C library.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/deducteam/dedukti.git")
+ (url "https://github.com/deducteam/dedukti")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3517,7 +3522,7 @@ collection.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/rlepigre/ocaml-bindlib.git")
+ (url "https://github.com/rlepigre/ocaml-bindlib")
(commit (string-append "ocaml-bindlib_" version))))
(file-name (git-file-name name version))
(sha256
@@ -3725,7 +3730,7 @@ format}. @code{craml} is released as a single binary (called @code{craml}).")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocaml/merlin.git")
+ (url "https://github.com/ocaml/merlin")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4169,7 +4174,7 @@ OCaml AST in the OCaml syntax;
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_compare.git")
+ (url "https://github.com/janestreet/ppx_compare")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4294,7 +4299,7 @@ new record values.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_sexp_conv.git")
+ (url "https://github.com/janestreet/ppx_sexp_conv")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4323,7 +4328,7 @@ definitions.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_variants_conv.git")
+ (url "https://github.com/janestreet/ppx_variants_conv")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4452,7 +4457,7 @@ storage of large amounts of data.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_hash.git")
+ (url "https://github.com/janestreet/ppx_hash")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4483,7 +4488,7 @@ hash functions from type exrpessions and definitions.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_enumerate.git")
+ (url "https://github.com/janestreet/ppx_enumerate")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4834,7 +4839,7 @@ useful errors on failure.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_expect.git")
+ (url "https://github.com/janestreet/ppx_expect")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4909,7 +4914,7 @@ packages.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_typerep_conv.git")
+ (url "https://github.com/janestreet/ppx_typerep_conv")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -4975,7 +4980,7 @@ verification tool.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/ppx_bin_prot.git")
+ (url "https://github.com/janestreet/ppx_bin_prot")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -5144,7 +5149,7 @@ Configurator allows one to:
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/spawn.git")
+ (url "https://github.com/janestreet/spawn")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -5192,7 +5197,7 @@ thousands of times faster than fork.
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/core.git")
+ (url "https://github.com/janestreet/core")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -5232,7 +5237,7 @@ standard library that was developed by Jane Street.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/janestreet/core_kernel.git")
+ (url "https://github.com/janestreet/core_kernel")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -5335,7 +5340,7 @@ stream, and convert everything to UTF-8.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ocsigen/tyxml.git")
+ (url "https://github.com/ocsigen/tyxml")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5370,7 +5375,7 @@ combinators.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/aantron/bisect_ppx.git")
+ (url "https://github.com/aantron/bisect_ppx")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5455,7 +5460,7 @@ complexity of the OCaml module system.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Chris00/fftw-ocaml.git")
+ (url "https://github.com/Chris00/fftw-ocaml")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5491,7 +5496,7 @@ library FFTW.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mmottl/lacaml.git")
+ (url "https://github.com/mmottl/lacaml")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5524,7 +5529,7 @@ convenience functions for vectors and matrices.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Chris00/ocaml-cairo.git")
+ (url "https://github.com/Chris00/ocaml-cairo")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5554,7 +5559,7 @@ and SVG file output.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/garrigue/lablgtk.git")
+ (url "https://github.com/garrigue/lablgtk")
(commit version)))
(file-name (git-file-name name version))
(sha256