summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fc45805958..7f80fc8a32 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -453,13 +454,18 @@ provers.")
;; and gtk+-quartz-2.0 once available.
(inputs
`(("gtk+" ,gtk+-2)
- ("gtksourceview" ,gtksourceview)
+ ("gtksourceview" ,gtksourceview-2)
("libgnomecanvas" ,libgnomecanvas)
("libgnomeui" ,libgnomeui)
("libglade" ,libglade)
("librsvg" ,librsvg)))
(arguments
`(#:tests? #f ; no check target
+
+ ;; Occasionally we would get "Error: Unbound module GtkThread" when
+ ;; compiling 'gtkThInit.ml', with 'make -j'. So build sequentially.
+ #:parallel-build? #f
+
#:phases
(modify-phases %standard-phases
(replace 'install