summaryrefslogtreecommitdiff
path: root/gnu/packages/nutrition.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/nutrition.scm')
-rw-r--r--gnu/packages/nutrition.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/nutrition.scm b/gnu/packages/nutrition.scm
index 90019f848c..0e03253cf1 100644
--- a/gnu/packages/nutrition.scm
+++ b/gnu/packages/nutrition.scm
@@ -52,11 +52,18 @@
(inputs
`(("pygtk" ,python2-pygtk)
("sqlalchemy" ,python2-sqlalchemy)
+ ("python-lxml" ,python2-lxml)
("python-pillow" ,python2-pillow)
("elib.intl" ,python2-elib.intl)))
(arguments
`(#:python ,python-2 ;exception and print syntax
- #:tests? #f)) ;tests look bitrotted
+ #:tests? #f ;tests look bitrotted
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (zero? (system* "python" "setup.py" "install" "--prefix"
+ (assoc-ref %outputs "out"))))))))
(home-page "http://thinkle.github.io/gourmet/")
(synopsis "Recipe organizer")
(description