summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 5fa7d55845..95d784c62a 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -43,14 +43,14 @@
(define-public chrony
(package
(name "chrony")
- (version "3.5.1")
+ (version "4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.tuxfamily.org/chrony/"
"chrony-" version ".tar.gz"))
(sha256
- (base32 "19ywl8a3lb2id7lcna5hp2g4pjnfwdc9ihr0fk6i9m45vdq2za0v"))))
+ (base32 "09f6w2x5h5kamb4rhcbaz911q1f730qdalgsn8s48yjyqlafl9xy"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((srfi srfi-26)
@@ -80,7 +80,8 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("libcap" ,libcap/next)
+ `(("gnutls" ,gnutls)
+ ("libcap" ,libcap)
("libseccomp" ,libseccomp)
("nettle" ,nettle)))
(home-page "https://chrony.tuxfamily.org/")
@@ -143,7 +144,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
;; to run as non-root (when invoked with '-u'.)
,@(if (string-suffix? "-linux"
(or (%current-target-system) (%current-system)))
- `(("libcap" ,libcap/next))
+ `(("libcap" ,libcap))
'())))
(arguments
`(#:phases