summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 1c3b8cd313..e9ae9fa466 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -39,7 +39,7 @@
(define-public ntp
(package
(name "ntp")
- (version "4.2.8p10")
+ (version "4.2.8p11")
(source
(origin
(method url-fetch)
@@ -53,7 +53,7 @@
"/ntp-" version ".tar.gz")))
(sha256
(base32
- "17xrk7gxrl3hgg0i73n8qm53knyh01lf0f3l1zx9x6r1cip3dlnx"))
+ "13i7rp1va29ffjdk08fvsfl6n47zzwsp147zhgb550k8agvkjjpi"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -145,7 +145,18 @@ minimalist than ntpd.")
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(;; Disable seccomp when it's not supported--e.g., on aarch64. See
+ ;; 'src/seccomp.c' for the list of supported systems.
+ #:configure-flags ,(if (any (lambda (system)
+ (string-contains (or
+ (%current-target-system)
+ (%current-system))
+ system))
+ '("x86_64" "i686" "arm"))
+ ''()
+ ''("--disable-seccomp-filter"))
+
+ #:phases (modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
;; The ancestor of 'SOURCE_DATE_EPOCH'; it contains the