summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index ce94557a8c..c8d81fbd22 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -128,7 +128,7 @@
(cons sigxfsz common)
common))
(("'/bin/sh'")
- (string-append "'" (assoc-ref inputs "bash") "/bin/sh'")))
+ (string-append "'" (search-input-file inputs "/bin/sh") "'")))
;; Fix hardcoded /usr/bin/env references.
(substitute* '("test/parallel/test-child-process-default-options.js"
@@ -245,7 +245,8 @@
(search-input-file inpts "/bin/python3")
(raise-exception e)))
(lambda ()
- (search-input-file inpts "/bin/python"))))
+ (search-input-file inpts "/bin/python"))
+ #:unwind? #t))
"configure"
flags))))
(add-after 'patch-shebangs 'patch-nested-shebangs
@@ -735,14 +736,14 @@ source files.")
(define-public node-lts
(package
(inherit node)
- (version "14.18.3")
+ (version "14.19.3")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "026nd6vihjdqz4jn0slg89m8m5vvkvjzgg1aip3dcg9lrm1w8fkq"))
+ "15691j5zhiikyamiwwd7f282g6d9acfhq91nrwx54xya38gmpx2w"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -814,7 +815,9 @@ source files.")
"test/parallel/test-dns-lookupService-promises.js"))
;; These tests require networking.
- (delete-file "test/parallel/test-https-agent-unref-socket.js")
+ (for-each delete-file
+ '("test/parallel/test-https-agent-unref-socket.js"
+ "test/parallel/test-corepack-yarn-install.js"))
;; This test is timing-sensitive, and fails sporadically on
;; slow, busy, or even very fast machines.
@@ -861,7 +864,7 @@ source files.")
(list ;; Runtime dependencies for binaries used as a bootstrap.
c-ares-for-node
brotli
- icu4c-67
+ icu4c-70
libuv-for-node
`(,nghttp2 "lib")
openssl
@@ -876,7 +879,7 @@ source files.")
(list bash-minimal
coreutils
c-ares-for-node
- icu4c-67
+ icu4c-70
libuv-for-node
llhttp-bootstrap
brotli