summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm52
1 files changed, 30 insertions, 22 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 5ec54b52eb..ce94557a8c 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2018-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
@@ -68,7 +68,7 @@
"032801kg24j04xmf09m0vxzlcz86sv21s24lv9l4cfv08k1c4byp"))
(modules '((guix build utils)))
(snippet
- `(begin
+ '(begin
;; Patch for compatibility with ICU 68 and newer, which
;; removed the public TRUE and FALSE macros.
(substitute* '("deps/v8/src/objects/intl-objects.cc"
@@ -90,8 +90,7 @@
(("deps/http_parser/http_parser.gyp") "")
(("deps/uv/include/\\*.h") "")
(("deps/uv/uv.gyp") "")
- (("deps/zlib/zlib.gyp") ""))
- #t))))
+ (("deps/zlib/zlib.gyp") ""))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--shared-cares"
@@ -153,6 +152,10 @@
;; This requires a DNS resolver.
(delete-file "test/parallel/test-dns.js")
+ ;; This test is timing-sensitive, and fails sporadically on
+ ;; slow, busy, or even very fast machines.
+ (delete-file "test/parallel/test-fs-utimes.js")
+
;; FIXME: This test fails randomly:
;; https://github.com/nodejs/node/issues/31213
(delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")
@@ -280,20 +283,20 @@
;; download them from the internet:
(format #t "nodedir=~a\n" out)))))))))
(native-inputs
- `(;; Runtime dependencies for binaries used as a bootstrap.
- ("c-ares" ,c-ares)
- ("http-parser" ,http-parser)
- ("icu4c" ,icu4c)
- ("libuv" ,libuv)
- ("nghttp2" ,nghttp2 "lib")
- ("openssl" ,openssl)
- ("zlib" ,zlib)
- ;; Regular build-time dependencies.
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("procps" ,procps)
- ("python" ,python-2)
- ("util-linux" ,util-linux)))
+ ;; Runtime dependencies for binaries used as a bootstrap.
+ (list c-ares
+ http-parser
+ icu4c
+ libuv
+ `(,nghttp2 "lib")
+ openssl
+ zlib
+ ;; Regular build-time dependencies.
+ perl
+ pkg-config
+ procps
+ python-2
+ util-linux))
(native-search-paths
(list (search-path-specification
(variable "NODE_PATH")
@@ -307,10 +310,11 @@
libuv
`(,nghttp2 "lib")
openssl
- python-wrapper ;; for node-gyp (supports python3)
+ python-wrapper ;for node-gyp (supports python3)
zlib))
(synopsis "Evented I/O for V8 JavaScript")
- (description "Node.js is a platform built on Chrome's JavaScript runtime
+ (description
+ "Node.js is a platform built on Chrome's JavaScript runtime
for easily building fast, scalable network applications. Node.js uses an
event-driven, non-blocking I/O model that makes it lightweight and efficient,
perfect for data-intensive real-time applications that run across distributed
@@ -731,14 +735,14 @@ source files.")
(define-public node-lts
(package
(inherit node)
- (version "14.18.1")
+ (version "14.18.3")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "1vc9rypkgr5i5y946jnyr9jjpydxvm74p1s17rg2zayzvlddg89z"))
+ "026nd6vihjdqz4jn0slg89m8m5vvkvjzgg1aip3dcg9lrm1w8fkq"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -812,6 +816,10 @@ source files.")
;; These tests require networking.
(delete-file "test/parallel/test-https-agent-unref-socket.js")
+ ;; This test is timing-sensitive, and fails sporadically on
+ ;; slow, busy, or even very fast machines.
+ (delete-file "test/parallel/test-fs-utimes.js")
+
;; FIXME: This test fails randomly:
;; https://github.com/nodejs/node/issues/31213
(delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")