summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 71f8388efc..1166a6b205 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1027,7 +1028,8 @@ transparently check connection attempts against an access control list.")
(sha256
(base32 "1rf3jmi36ms8jh2g5cvi253h43l6xdfq0r7mvp95va7mi4d014y5"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-static")))
+ (arguments '(#:configure-flags '("--disable-static"
+ "--enable-drafts")))
(home-page "https://zeromq.org")
(synopsis "Library for message-based applications")
(description
@@ -1441,14 +1443,14 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.4.6")
+ (version "3.4.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0a26kcj3n1a2kw1f3fc6s1x3rw3f3bj2cq6rp7k0kc4ciwh7i9hj"))))
+ (base32 "17d00kl0s010wg2dfhy7sdbr2qm54lsi317fmbcvjz4rxx8ywk3c"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -1461,8 +1463,7 @@ of the same name.")
(lambda _
(substitute* "CMakeLists.txt"
(("suite_unittests" all) (string-append "# " all))
- (("suite_extcaps" all) (string-append "# " all)))
- #t)))
+ (("suite_extcaps" all) (string-append "# " all))))))
;; Build process chokes during `validate-runpath' phase.
;;
;; Errors are like the following: