summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 57a02e9f4a..5d1c432da3 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,12 +32,12 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages networking)
- #:use-module (guix build-system perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -64,7 +65,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
- #:use-module (gnu packages valgrind))
+ #:use-module (gnu packages valgrind)
+ #:use-module (ice-9 match))
(define-public macchanger
(package
@@ -433,7 +435,7 @@ and up to 1 Mbit/s downstream.")
(define-public whois
(package
(name "whois")
- (version "5.2.15")
+ (version "5.2.16")
(source
(origin
(method url-fetch)
@@ -441,7 +443,7 @@ and up to 1 Mbit/s downstream.")
name "_" version ".tar.xz"))
(sha256
(base32
- "123ingf699javzh8qm6ny10nl28zbjzasa4k5pcn0qzw1dlnnnks"))))
+ "0fpwac26ja0rdqsbxyjcsk8gxgixfpxk0baj3rhnpaff3jv0ilp9"))))
(build-system gnu-build-system)
;; TODO: unbundle mkpasswd binary + its po files.
(arguments
@@ -634,7 +636,12 @@ live network and disk I/O bandwidth monitor.")
"libnl=true"
"pcre=true"
"experimental=true" ;build wesside-ng, etc.
- "AVX2FLAG=N" "AVX1FLAG=N" "SSEFLAG=Y"
+ "AVX2FLAG=N" "AVX1FLAG=N"
+ ,,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ `("SSEFLAG=Y"))
+ (_
+ `("NEWSSE=false")))
,(string-append "prefix=" %output))
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configure phase