summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm43
1 files changed, 36 insertions, 7 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5bf2d9d225..ca37b58ab0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -142,6 +142,35 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public usrsctp
+ (package
+ (name "usrsctp")
+ (version "0.9.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sctplab/usrsctp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10ndzkip8blgkw572n3dicl6mgjaa7kygwn3vls80liq92vf1sa9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("which" ,which)))
+ (home-page "https://github.com/sctplab/usrsctp/")
+ (synopsis "SCTP user-land implementation")
+ (description "UsrSCTP is a portable SCTP userland stack. SCTP is a message
+oriented, reliable transport protocol with direct support for multihoming that
+runs on top of IP or UDP, and supports both v4 and v6 versions.")
+ (license license:bsd-3)))
+
(define-public axel
(package
(name "axel")
@@ -1357,14 +1386,14 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.4.3")
+ (version "3.4.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0ar6pxzrcpxdriz437d6ziwlhb8k5wlvrkalp3hgqwzwy1vwqrzl"))))
+ (base32 "0aad3m8nh4i75dgjs68217135bzqmhmlgjklmpjh1ihmjwgd373j"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -2595,8 +2624,9 @@ does not use SSH and requires a pre-shared symmetric key.")
(version "1.2.4")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/quagga/quagga-"
- version ".tar.gz"))
+ ;; Use archived sources; see <http://issues.guix.gnu.org/47123>.
+ (uri (string-append "https://fossies.org/linux/misc/"
+ "quagga-" version ".tar.gz"))
(sha256
(base32
"1lsksqxij5f1llqn86pkygrf5672kvrqn1kvxghi169hqf1c0r73"))
@@ -3910,7 +3940,7 @@ network.")
(define-public yggdrasil
(package
(name "yggdrasil")
- (version "0.3.15")
+ (version "0.3.16")
(source
(origin
(method git-fetch)
@@ -3921,8 +3951,7 @@ network.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0gk7gy8yq5nrnblv4imxzzm2hac4ri0hlw19ajfbc1zll5kj32gf"))
+ (base32 "0vyd7a333hwn6j1lv1g9sicw74a4qk982bsi3cfdhjlv6hsjwmil"))
(patches (search-patches "yggdrasil-extra-config.patch"))))
(build-system go-build-system)
(arguments