summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm106
1 files changed, 82 insertions, 24 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 85c43efd50..1c2e7cf979 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -259,23 +259,35 @@ GLib-based library, libnice, as well as GStreamer elements to use it.")
(define-public rtmpdump
(package
(name "rtmpdump")
- (version "2.3")
+ (version "2.4")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://rtmpdump.mplayerhq.hu/download/"
- name "-" version ".tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.ffmpeg.org/rtmpdump")
+ (commit "c28f1bab7822de97353849e7787b59e50bbb1428")))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0b2b49a57kpz9gi8dx1x3cs8b0gjx8x0c89x0q96kkl2knlvff7g"))))
+ (base32 "1n3kdip83nvvs4sin30zpcdr5q711mqhq2lxrv5vgbc6lskpwzlj"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No tests
+ `(#:tests? #f ; no tests
#:make-flags
(list
+ ;; The ‘validate-runpath’ phase fails to find librtmp.so.0.
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'omit-static-library
+ (lambda _
+ (substitute* "librtmp/Makefile"
+ (("cp librtmp\\.a .*") ; don't install it
+ "")
+ (("librtmp\\.a ") ; don't build it
+ ""))
+ #t))
(delete 'configure))))
(inputs
`(("openssl" ,openssl-1.0)
@@ -367,6 +379,28 @@ sockets, and also some helper utilities around SCTP.")
;; Others.
license:gpl2+))))
+(define-public knockd
+ (package
+ (name "knockd")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zeroflux.org/proj/knock/files/knock-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "193qcpsy7v51c6awhg9652l5blyz8vp6n7y6fi7l4rhh6af4ff4r"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (home-page "https://www.zeroflux.org/projects/knock")
+ (synopsis "Small port-knock daemon")
+ (description "@command{knockd} is a port-knock daemon. It listens to all traffic on
+an ethernet or PPP interface, looking for special \"knock\" sequences of @dfn{port-hits}
+(UDP/TCP packets sent to a server port). This port need not be open, since knockd listens
+at the link-layer level.")
+ (license license:gpl2+)))
+
(define-public nng
(package
(name "nng")
@@ -1495,14 +1529,14 @@ TCP connection, TLS handshake and so on) in the terminal.")
(define-public squid
(package
(name "squid")
- (version "4.12")
+ (version "4.13")
(source
(origin
(method url-fetch)
(uri (string-append "http://www.squid-cache.org/Versions/v4/squid-"
version ".tar.xz"))
(sha256
- (base32 "05z34ysy2zn7as11vd365xxhh36bm1ysiwcbr0i0f0nwng406apl"))))
+ (base32 "1q1ywpic6s7dfjj3cwzcfgscc4zq0aih462gyas7j1z683ss14b8"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -2073,14 +2107,14 @@ HTTP proxies.")
(define-public enet
(package
(name "enet")
- (version "1.3.15")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://enet.bespin.org/download/"
- "enet-" version ".tar.gz"))
- (sha256
- (base32
- "1yxxf9bkx6dx3j8j70fj17c05likyfibb1419ls74hp58qrzdgas"))))
+ (version "1.3.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://enet.bespin.org/download/"
+ "enet-" version ".tar.gz"))
+ (sha256
+ (base32 "1lggc82rbzscci057dqqyhkbq4j6mr5k01hbrvn06jkzc2xpxdxv"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -3394,14 +3428,14 @@ maximum extent possible.")
(define-public batctl
(package
(name "batctl")
- (version "2020.1")
+ (version "2020.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://downloads.open-mesh.org/batman/releases/batman-adv-"
version "/batctl-" version ".tar.gz"))
(sha256
- (base32 "0fy252q1my3a57v6pfz8i97h6zv7v03di01dhwjkj47pqnx1rqm3"))))
+ (base32 "0r2w2v4sy6wgr7mp9lc7yj9k4ldsbsm3425rjil7p0b17zmzf4rm"))))
(inputs
`(("libnl" ,libnl)))
(native-inputs
@@ -3427,7 +3461,7 @@ module @code{batman-adv}, for Layer 2.")
(define-public pagekite
(package
(name "pagekite")
- (version "1.5.2.200603")
+ (version "1.5.2.200725")
(source
(origin
(method git-fetch)
@@ -3436,7 +3470,7 @@ module @code{batman-adv}, for Layer 2.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "08rcyr54dssnpand6y26f8x9cjmd91hr44my08kxw70s5iqiwizv"))))
+ (base32 "0lig1i42bn9isw848vnml5qhcaa04x1dr2hb075bm0a3439kv3rr"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3639,15 +3673,14 @@ thousands of connections is clearly realistic with today's hardware.")
(define-public lldpd
(package
(name "lldpd")
- (version "1.0.5")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://media.luffy.cx/files/lldpd/lldpd-"
version ".tar.gz"))
(sha256
- (base32
- "16fbqrs3l976gdslx647nds8x7sz4h5h3h4l4yxzrayvyh9b5lrd"))
+ (base32 "1v5fd8vwxracvzvgrsswvhppwyx5c4srj89g1cnvy73w831mpq95"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3728,3 +3761,28 @@ hashcash stamps efficiently.
This package contains a command-line tool for computing and verifying hashcash
stamps.")
(license license:public-domain)))
+
+(define-public nbd
+ (package
+ (name "nbd")
+ (version "3.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/nbd/nbd/3.20/nbd-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1kfnyx52nna2mnw264njk1dl2zc8m78sz031yp65mbmpi99v7qg0"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (home-page "https://nbd.sourceforge.io/")
+ (synopsis "NBD client and server")
+ (description "This package provides the NBD (Network Block Devices)
+client and server. It allows you to use remote block devices over a TCP/IP
+network.")
+ (license license:gpl2)))